当前博客:火山PC调用易语言的能力实现禁止软件重复运行

298 次浏览

匿名大神

增强知识,努力学习
1、首先利用建立一个易语言dll动态链接库项目。




2、调用以下两个系统api,大概就是,前一个方法用于判断标记是否存在,后一个方法用于设置标记。
    这样通过这个标记信息的判断,可以确定当前软件是否运行。



.版本 2

.DLL命令 OpenEventA, 整数型, "kernel32.dll", "OpenEventA", 公开, 打开事件同步对象,判断标记是否存在
    .参数 dwDesiredAccess, 整数型
    .参数 bInheritHandle, 逻辑型
    .参数 lpName, 文本型

.DLL命令 CreateEvent, 整数型, "Kernel32.dll", "CreateEventA", 公开, 创建事件同步对象,创建一个标记
    .参数 lpEventAttributes, 整数型
    .参数 bManualReset, 逻辑型
    .参数 bInitialState, 逻辑型
    .参数 lpName, 文本型




3、调用以上两个api函数,简单的封装一下,实现一个判断当前软件是否运行的子程序。
    注意:这里的标记文本要尽量的复杂,如果软件已经运行返回真,否则返回假。


.版本 2

.子程序 chongfu, 逻辑型, 公开, 禁止当前程序多开运行
.局部变量 局_句柄, 整数型
.局部变量 hEvent, 整数型

hEvent = OpenEventA (2031619, 假, “abcdefghc”)  ' 判断标记是否存在
.如果真 (hEvent ≠ 0)
    返回 (真)
.如果真结束
CreateEvent (0, 假, 假, “abcdefghc”)  ' 写一个标记
返回 (假)





4、最后进行静态编译。




5、建立视窗项目,在启动类利用“@视窗.附属文件”属性选择dll,用于输出dll到程序目录中
6、建立“禁止重复运行”方法,引入dll,并填写输出名返回值等信息,务必和易语言中的保持一致。
7、在启动方法中,判断“禁止重复运行”是否返回真,如果返回真就弹出提示,否则就创建主窗口。





8、最后运行效果,可以看到软件打开一次后就无法打开第二次。会提示禁止运行。









例程下载:点击本链接



1、首先利用建立一个易语言dll动态链接库项目。




2、调用以下两个系统api,大概就是,前一个方法用于判断标记是否存在,后一个方法用于设置标记。
    这样通过这个标记信息的判断,可以确定当前软件是否运行。



.版本 2

.DLL命令 OpenEventA, 整数型, "kernel32.dll", "OpenEventA", 公开, 打开事件同步对象,判断标记是否存在
    .参数 dwDesiredAccess, 整数型
    .参数 bInheritHandle, 逻辑型
    .参数 lpName, 文本型

.DLL命令 CreateEvent, 整数型, "Kernel32.dll", "CreateEventA", 公开, 创建事件同步对象,创建一个标记
    .参数 lpEventAttributes, 整数型
    .参数 bManualReset, 逻辑型
    .参数 bInitialState, 逻辑型
    .参数 lpName, 文本型




3、调用以上两个api函数,简单的封装一下,实现一个判断当前软件是否运行的子程序。
    注意:这里的标记文本要尽量的复杂,如果软件已经运行返回真,否则返回假。


.版本 2

.子程序 chongfu, 逻辑型, 公开, 禁止当前程序多开运行
.局部变量 局_句柄, 整数型
.局部变量 hEvent, 整数型

hEvent = OpenEventA (2031619, 假, “abcdefghc”)  ' 判断标记是否存在
.如果真 (hEvent ≠ 0)
    返回 (真)
.如果真结束
CreateEvent (0, 假, 假, “abcdefghc”)  ' 写一个标记
返回 (假)





4、最后进行静态编译。




5、建立视窗项目,在启动类利用“@视窗.附属文件”属性选择dll,用于输出dll到程序目录中
6、建立“禁止重复运行”方法,引入dll,并填写输出名返回值等信息,务必和易语言中的保持一致。
7、在启动方法中,判断“禁止重复运行”是否返回真,如果返回真就弹出提示,否则就创建主窗口。





8、最后运行效果,可以看到软件打开一次后就无法打开第二次。会提示禁止运行。









例程下载:点击本链接



博客推荐
阅览:102
用户:匿名大神
用户上传   2021-6-16
阅览:223
用户:匿名大神
用户上传   2021-6-16
阅览:227
用户:匿名大神
用户上传   2021-6-16
阅览:287
用户:城北
用户上传   2021-6-15
阅览:259
阅览:251
用户:匿名大神
用户上传   2021-6-15
阅览:243
用户:匿名大神
用户上传   2021-6-15
阅览:253
用户:航母上看风景
用户上传   2021-6-14